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1 Why use R 
R is a commonly used programming language in Computer Science. While it is possible to do much of 
the same computation in other programming languages (like Python), R has some great benefits. 

The benefits of R include: 

- Free of charge and open source 
- Highly flexible and provides many statistical and graphical techniques 
- Optimized for vector operations 

o Great for going through a row or table 
- Many resources online to find help 
- Many available packages 

o Packages add new functions to R 
 Base-packages:  

Installed with R, but not loaded by default 
 Contributed (3rd party)-packages:  

Need to be downloaded, installed, and loaded separately 
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2 How to download R and RStudio 
To get started with R, follow the steps below: 

1. Go to the website: https://www.r-project.org/  
2. Under the Download menu on the left, click CRAN. 

 
3. Click the link under “0-Cloud” as shown on the screenshot below.  

 
4.  Click the link that suits your computer’s operating system. 

 
5. Start the download: 

a. Mac 
Download the newest release. 

b. Windows 
Click “base” and download the newest release. 

 
6. Follow the standard downloading steps, the download should only take a minute. 

https://www.r-project.org/
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The next thing you should do, is to download an integrated development environment (IDE) for R, 
called RStudio.  

1. Go to the website: https://www.rstudio.com/  
2. Navigate to the download page via: Products -> Open Source -> RStudio 

 
3. Chose the desktop version. 

 

https://www.rstudio.com/
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4. Download the free version. 

 
5. Follow the standard downloading steps. 
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3 How to use RStudio 

 

After opening the RStudio program, we get this window. As you can see, the main window is divided 
into four smaller windows. 

Upper left window: “Source” 
This window allows us to open, edit and run R-scripts. When writing a script, remember to save it 
with File -> Save.  
It also displays data sets that are imported to R, like an Excel file. 

Lower left window: “Console” 
The console allows us to run R code one line at a time and execute our command when we hit Enter. 
The output (if any) will be displayed in the next line, every row of the output indexed by [1], [2], … 
Tip: To clear the console, use the shortcut Ctrl + L. 
You can also find this option in Edit -> Clear Console. 

Upper right window: “Environment, History, Connections” 
The Environment tab shows the objects (data and variables) that have been loaded or created in the 
workspace you are working on. 
The History tab is a log of executed commands. 

Lower right window: “Files, Plots, Packages, Help, Viewer” 
The Files tab shows your current directory. It can be useful to create a dedicated folder that you do 
your work in. To change directory, use Session -> Set Working Directory -> Choose Directory…  
This can also be done directly in the console with the command: setwd(“<name of the directory>”), 
for instance:  

 
If you want to change the default working directory, use Tools -> Global Options… and change the 
directory from there. 
The Plots tab are where the plots will be shown when you create them. 
The Packages tab shows what libraries are installed and loaded into the current session memory. You 
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can load packaged by ticking off the box to the left. 

 
Alternatively, you can load them in the console with the command: 

  
The Help tab is used for instance when you want to look up the documentation of a function, which 
you can always do from the console with the function ?<function name>. 
For instance: 
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4 Basic commands 
4.1 How to use packages 
Libraries are groups of functions and data sets, and they must be loaded before you can use them. 
Some libraries already got downloaded when you installed R and RStudio, and can be loaded with the 
function library(): 

 

The library “MASS” contains a lot of data sets and useful functions. 

Other libraries must first be installed (the first time you ever use them), and then loaded when you 
want to use them. Here I want to load the ISLR library, which contains data sets associated with the 
book “An introduction to statistical learning”. 

 

The error message implies that the package ISLR is not downloaded, so let’s do that: 

 

Now you can load the library as usual.  

Alternatively, you can use Tools -> Install Packages and enter the packages you want to install. 

   

Since you likely will be using Excel together with R, you should try to install the packages that 
contains functions to read data from Excel sheets (‘.xls’ and ‘.xlsx’ files).  
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NB: The library() function must be executed every time you want to use a given package. You can 
check if a package is loaded in the Packages tab in the lower right window. 

When you are done with R, you can detach the packages with the function detach(), or by 
unchecking the package in the Packages tab. 

 

4.2 Import data from Excel 
The easiest way to import a dataset from Excel, is by File -> Import Dataset -> From Excel… 

You will get this window, where you click Browse… and find the file you want to import. Then click 
Import at the lower right to execute the import. 

 

Note that the datatypes of the variables (for instance the values in the Height column are interpreted 
as Double) can be changed from this window, using the drop-down menu.  



10 
 

The lower right sub window (Code Preview) shows the corresponding R code to import the data set, 
and you can note that the actions we take simply corresponds to code that could be directly written 
in the console: 

 

NB: Note that on line two the operator ‘<-‘ is used. This has the same effect as using ‘=’. 

4.3 Data description 
After loading the data in section 4.2, you can find a description of the dataset in the Environment tab. 

 

To find the dimensions of the table, use the function dim(): 

 

The table has 4 rows and 5 columns. 

To get some basic summary statistics of the dataset, we can run the function summary() with the 
dataset as it’s parameter (input variable). 

 

Instead of a summary, we could use the specific functions: mean(), median(), quantile, min(), max() 
and sd(). Other useful functions are cor() for correlation between two vectors, and var() to find the 
variance between to vectors. 

To target only one of the variables in the dataset, we can use <dataset>$<variable>. 

 

Tip: If you are only using one dataset, you can attach it with the function attach(<dataset>). When 
this is done, you can simply write the variables without the need for <dataset>$ in front. 

A list of all the variables in the dataset is obtained by the function names(). 
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A quick way to check that the data is loaded properly, is with the function head(). This displays the 
first 6 rows of the dataset in the console. 

  

4.4 Changing and creating data 
NB: Even though R allows for white spaces to be part of the variable name, this is bad practice and 
should be avoided for future problems. 

To address a specific entry in a vector or matrix, we use square brackets ‘[]’. 

If I want to address the second entry of the variable names in PeopleTable_R, this can be done by: 

 

Note: Indexing in R starts at 1 and not 0. 

Changing names of variable names is simple, for instance: 

 

The second line is just to illustrate that the variable has changed name. 

In some cases, you want to add another column in the dataset, and this can be done in R. 

 

 

Another way to edit the dataset is with the function fix(). 
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When the fix-function is executed, a new window opens (as you can see above). From this window it 
is possible to edit the data set. 

For an overview of commonly used operators, you can refer to the following table: 

Operation Explanation 
a / b a divided by b 
a * b a multiplied by b 
a^b a to the power of b 
log(a) Logarithm of a 
exp(a) Taking the exponential 
sqrt(a) Square root of a 
abs(a) Absolute value of a 
== (exactly) equal 
!= Not equal 
> Larger than 
< Smaller than 
>= Larger or equal 
<= Smaller or equal 
& Logical AND 
| Logical OR 
! Logical NOT 

 

4.5 Saving to workspace 
It is useful to save the work you have done, so you can open it later. To do this, you can save the 
session by clicking Session -> Save Workspace As… 

Also useful is to save the instructions you have used in an R script, and this can be saved from  
File -> Save. These scripts can be created by File -> New File -> R Script. To open them, click File -> 
Open Files… and locate your script. To run a line in the script, press Ctrl + Enter, with the cursor in the 
respective line. To run the entire script, mark everything and press Ctrl + Enter. 

Tip: Comments in R are created by the starting cue ‘#’. It is highly recommended to comment code 
that is not self-explanatory. 

To shut down R, we can use the function q(). Then we will be given the choice to save the current 
workspace (all objects created will be saved and can be used later).  

 

After typing “y” or “n”, the window closes down. 

Before we exit, we can also save the history from the console (what lines we have typed in) with the 
function savehistory(). To load, we use the function loadhistory() next time.  
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5 Graphics (and plots) 
The graphics in R have some standard parameters, so they look the same every time. To change 
these, you can use the par() function. For more information, type ?par in the console. 

Plotting the Weight on the x-axis, and Height on the y-axis can be done like this: 

 

 

To show some of the possible improvements for this simple plot, this is an example: 
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We can also create a line plot: 
(Note that I create a new dataset ‘t1’ where the data is ordered by weight) 

 

 

Use ?plot for more information on how to use this function. 

There are numerous ways to save the plots, for instance in the Plots tab: 

 

An interactive way of identifying points on a plot, is by the function identify(). The first two 
arguments are the variables for the x-axis and y-axis, and thirdly we chose what variable we want to 
know about a given point. After the identify() line is executed, simply click on the points in the plot 
you want to identify, and when you are done, press Esc. The values will be printed in the console, as 
well as displayed in the plot. 
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Histograms can also be a simple but very useful plot and is made by the function hist(). 

 

 

These can also be refined by some arguments, see ?hist for more. 
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It also possible to create boxplots in R with the function boxplot(), where the first input is the 
relation between the variables Height and Gender in this case, both from the dataset PeopleTable_R.  

  

   

To get more control we can use parameters. 

Tip: To clear the Plot tab, you can use the function dev.off() in the console. 

5.1 More advanced plots 
To produce a contour plot (used to represent three-dimensional data; somewhat like a topographical 
map) in R, we use the function contour(). 

The most important input variables (arguments) to the contour() function, are the grid lines (usually x 
and y) and a matrix (z) containing the values to be plotted. Here I will illustrate an example based on 
the code in p.46 in “An introduction to statistical learning”.  
Note that the function outer() takes the arguments vector x, vector y, and a function.  The outer 
function applies this function to the two vectors. 

 

When the fourth line is executed, we get the plot: 
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If we prefer to decide the number of levels in the plot, we can do this by explicit changing the 
nlevels-argument. 
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The function image() is very similar to contour(), but gives us a color-coded plot (heatmap): 

 

 

For a three-dimensional plot, we can use the function persp(). Theta and phi are used to control at 
what angle we view the plot. 

 

 

For more information about these different plots, the help sites (?contour, ?image, ?persp) are 
recommended. 
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6 Sequences, vectors, matrices, and random numbers 
6.1 Create a sequence of numbers 
It can be useful to create a sequence of numbers, and this is done with the function seq(). 

To create a vector of integers between 1 and 10 (both inclusive): 

 

In short, we could equally write: 

  

To create a vector of equally spaced numbers from 0 to 1 with length 10: 

 

6.2 Vectors in R 
To create a vector in R, we use the function c(), for concatenate. 
The vector [1, 2, 7] is created by typing: c(1, 3, 7)  

To save the vector to a variable x (you can call it whatever you want), we can use the syntax <- or =, 
both have the same effect. Typing the variable x in the console would now display the vector. 

 

We can use mathematical operations on vectors, such as addition (+): 

 

To find the length of a vector, we use the function length(). 

  

6.3 Objects stored 
It might be useful to get an overview of what objects (such as data and functions) we have saved so 
far. We can get a list of such objects with the function ls() [starting with a small L, ls() is short for list]. 

  

To remove objects, we use rm(). In the parenthesis we put the objects we want to remove. 

rm(x) to remove the object x. 
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rm(list=ls()) to remove all objects. 

  

6.4 Matrices 
To create a matrix in R, we use the function matrix(). It takes multiple inputs, the first three are: data 
(the actual numbers in the matrix), number of rows, number of columns.  

To create the matrix 𝐴𝐴 = �
1 4
2 5
3 6

� we write:  

 

You can also split up on multiple lines: 

 
(The +-signs are created automatically. To shift line without executing the line, use Shift + Enter.) 

Or in short write: 

 

All of the above will give the same result. For the last one, it is important to not mix up the move 
order of the inputs, check with ?matrix to find out more. 

The standard way of distributing the data in the matrix in R, is to use the data to fill up first column, 
then second column, and so on. It is possible to have the program start filling up first row, the second 
row, and so on -by using the additional input: 
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Equally correct you could write: 

 

Multiple commands can be used on matrices, for instance we can raise every element in the matrix 
to the power of 𝑝𝑝,𝑓𝑓𝑓𝑓𝑓𝑓 𝑎𝑎𝑎𝑎𝑎𝑎 𝑝𝑝 ∈ ℝ, with the command x^p. For 𝑥𝑥0.5 we can use the syntax sqrt(x).  

  

To index the matrix, simply write: 

 

We can also select multiple rows and columns: 

 
The 1 is found in x[1,1], 2 in x[1,2], 5 in x[3,1] and 6 in x[3,2]. 

Also possible is: 

  

Or: 

 (in this case, the blank will index all rows) 

To index every row except the listed, we use minus (-): 
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To find the dimension of a matrix, use the function dim(): 

  x has 3 rows and 2 columns 

6.5 How to deal with missing values 
Missing values are represented by ‘NA’, for Not Available. 
Impossible values (for instance: 1

0
) are represented by ‘NaN’, for Not a Number. 

This section will look at how to deal with missing values in a vector, matrix, or a dataset.  

6.5.1 Missing values in a vector 
To check for missing values, we can use the function is.na(). 

 

If we want to recode a certain value to missing value, this can be done with by:  

 

When doing analysis of vectors, we should exclude the missing values from the calculation. 

 

Note that the vector y is not changed, only in the calculation of the mean is the NA-values removed. 

To omit the missing values and save the new vector in another variable, we can use na.omit(). 
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In the Environment tab to our upper right, we can get an overview of our variables. 

 

A quick way to count the number of missing values in a dataset, is by sum(is.na()). 

  

As we can see, the vector y clearly has two missing values. 

6.5.2 Missing values in a matrix 
The logic and functions around missing values for vectors can be extended to matrices. 

 

Finding the missing values in the matrix A: 

 

Replace a value (here: -1) with ‘NA’ in the matrix B: 

 

To find the mean, we must first exclude the missing values: 
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Using the na.omit() function on matrices, R removes all rows that contains missing values. 

 

Counting the number of missing values works the same way as for vectors. 

 

6.6 Random variables 
To generate a vector of n numbers of random normal variables in R we use the function rnorm(n).  

  

By default, it creates n number of random variables with mean of 0 and standard deviation of 1. This 
can be altered, for instance by using the inputs: rnorm(10, mean=50, sd=0.1). (Here n=10) 

  

Every time the function is called, we get a different answer. The reproduce the same set of random 
numbers every time, we can use the function set.seed() before we use the rnorm(n) function. The 
input should be an (arbitrary) integer. We can now do: 

 

Every time we use the same seed, we get the same randomly generated vector. 
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7 Functions, loops, and conditional execution 
7.1 How to create a function 
Creating functions are intuitive in R. We must use function(), and first specify the input variables (for 
instance x and y). Then we specify how the function will map these inputs to an output (for instance 
𝑓𝑓(𝑥𝑥,𝑦𝑦) = 2𝑥𝑥 + 𝑦𝑦2 ). At last, we write what the function will return -this is completely up to us (for 
instance we can return the input values and the output value in the form 𝑐𝑐(𝑥𝑥,𝑦𝑦, 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣) ). 

 

Note that the ‘+’ signs are automatically added by R. To use multiple lines, press Shit + Enter to jump 
to next line without executing any code yet.  

7.2 How to see the code inside a function 
For simple functions, the source code of the function will not give you much extra information. 
However, for more complicated functions, this can be useful -and it’s very easy to do. 

For functions in R that comes from the base package, simply write the function name in the console: 
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In R there are different type of classes, some stricter than others. For instance, the S4 class requires a 
formal definition and a uniform way to create objects, unlike the S3 class. 

I will use the S4 function show() in this example. If you try to type the function name, you will get: 

 

To see that this is a S4 function, we can use isS4(). 

 

The proper way to see its source code is first to find the object it belongs to. 
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Then we check for the method we are interested in. 

 

7.3 How to create loops 
Loops can be created by: for (variable in vector) {…} 

 

The variable ‘v’ is first assigned an empty vector. For every iteration in the loop, the vector expands 
by adding the value of ‘i’ at the end of the vector.  

7.4 How to do conditional execution 
If-else statements can be created by: if (condition) {…} else {…} 

 

The variable ‘i’ is assigned the value 0. Our if-statements checks whether ‘i’ is equal to ‘0’. Since it is, 
the line ‘a = 10’ is executed. The else part is not executed in this case. 
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8 Linear Regression 
To illustrate how to do simple statistical calculations and linear regression in R, I will use the Excel 
sheet ‘PeopleTable_R’ as shown below: 

 

To import files from Excel, see section 4.2. 

To acquire some basic statistical values from the dataset, we can use summary() as mentioned in 
section 4.3.  

 

To estimate linear models, we use the function lm(). The first argument should be on the form 𝑦𝑦 ~ 𝑥𝑥 
for variables y and x, where y is the dependent variable and x the independent variable. As a second 
argument, we must specify the dataset these variables are attained from. 

Say we want to predict the height of a person with a given weight. To do this, we fit a simple linear 
regression model to these variables by using the function lm(). 

 

This does not print any output, but we can observe in the Environment tab that the variable 
lm_returns has been created and contains some data. 

 

To see some basic information about the model, we can call our variable lm_returns. 

 

We observe that the parameter estimates for the intercept (𝛼𝛼�) is 121.4385 and the slope �𝛽̂𝛽� is 
0.7921. That is, the function 𝑓𝑓(𝑥𝑥) = 121.4385 + 0.7921𝑥𝑥 is the best fitting linear line of our four 
points of (< 𝑊𝑊𝑊𝑊𝑊𝑊𝑊𝑊ℎ𝑡𝑡 >, < 𝐻𝐻𝐻𝐻𝐻𝐻𝐻𝐻ℎ𝑡𝑡 >). 
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To get a summary of all the data created in lm_returns, we can use the summary() function. 

 

This gives us: p-values, standard errors for the coefficients, 𝑅𝑅2 statistic and 𝐹𝐹-statistic for the model. 

We can run names(lm_returns) to find more information stored in the variable: 

  

To extract the quantities, we can use for instance: 

 

A safer way to do this is by using extractor functions like coef(): 

  

To find the confidence interval for the coefficient estimates, we use the function confint(). As we see 
below, the 95% confidence interval is the standard unless otherwise specified. 
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To produce confidence intervals and prediction intervals for the prediction of height for a given value 
of weight, we use the function predict(). 

 

In this case the 95% confidence interval associated with weight=65 is (159.11, 186.74), while the 
95% prediction interval is (144.67, 201.18). Naturally they both have the same predicted value 
(172.93 when weight is 65), where the predict interval is bigger than the confidence interval. 

To plot the regression line, we can use abline(): 

 

 

 

8.1 More statistical plots connected to the linear model 
There are four diagnostics plots we can view by applying plot() function to the output from lm(). To 
view all of the four plots at once, we can use: 
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If you do not use the first line, you will be able to see one plot at a time, using Enter to switch to the 
next plot.  

The residuals from the linear regression fit can also be computed with residuals(). 

  

  

The function rstudent() returns the studentized residuals, which can be plotted against the fitted 
values. 
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As a last example, the hatvalues() function can compute leverage statistics, which we can plot: 

 

 

   


	1 Why use R
	2 How to download R and RStudio
	3 How to use RStudio
	4 Basic commands
	4.1 How to use packages
	4.2 Import data from Excel
	4.3 Data description
	4.4 Changing and creating data
	4.5 Saving to workspace

	5 Graphics (and plots)
	5.1 More advanced plots

	6 Sequences, vectors, matrices, and random numbers
	6.1 Create a sequence of numbers
	6.2 Vectors in R
	6.3 Objects stored
	6.4 Matrices
	6.5 How to deal with missing values
	6.5.1 Missing values in a vector
	6.5.2 Missing values in a matrix

	6.6 Random variables

	7 Functions, loops, and conditional execution
	7.1 How to create a function
	7.2 How to see the code inside a function
	7.3 How to create loops
	7.4 How to do conditional execution

	8 Linear Regression
	8.1 More statistical plots connected to the linear model


